Windows XP Tipps und Tricks Super-Guide
Die besten Tipps für Windows XP: Mit
dieser umfassenden Sammlung undokumentierter Experten-Tricks optimieren
Sie Performance, Netzwerk, Oberfläche und Sicherheit Ihres
Betriebssystems.
Von Jason Curtis
16. Januar 2004, 16:13 Uhr
Wie
jedes frisch installierte OS ist auch Windows XP in seinen
Standardeinstellungen alles andere als optimal konfiguriert. Doch mit
sinnvollen Tuning-Maßnahmen und einfachen Problemlösungen holen auch
Sie das beste aus Ihrem System heraus.
Optimieren Sie
mit unserer Sammlung getesteter Experten-Tipps für Windows XP
grundlegend die Performance, Bedienbarkeit und Sicherheit Ihres
Betriebssystems.
Windows XP Wiederherstellungskonsole installieren
Die Windows XP Wiederherstellungskonsole ist ein hilfreiches Tool für den Notfall. Sie ermöglicht beschränkten Zugriff auf NTFS-, FAT- und FAT32-Partitionen und erlaubt somit das Kopieren, Umbenennen oder Ersetzen von wichtigen Betriebssystemdateien, die Reparatur des Master Boot Records und noch einiges mehr. Standardmäßig jedoch wird die Wiederherstellungskonsole nicht mitinstalliert.

So installieren Sie die Windows XP Wiederherstellungskonsole auf Ihrem System:
Eingabe: D: (wo "D" der Laufwerksbuchstabe der CD-ROM ist) und dann cd i386
winnt32.exe /cmdcons
Beim nächsten Neustart steht die Windows XP Wiederherstellungskonsole im XP-Bootmenü zur Verfügung.
Weitere Informationen zur Wiederherstellungskonsole und zur Erweiterung seiner Funktionalität erhalten Sie hier:
Sicherheitstest für Windows XP
Der Microsoft Baseline Security Analyzer (MBSA) ist ein kostenloses Tool zur Überprüfung von Windows 2000, Windows XP und Windows Server 2003 auf Schwachstellen in der Sicherheitskonfiguration, sowie auf das Vorhandensein verfügbarer Patches und Updates. Warnungen und Empfehlungen werden übersichtlich angezeigt, und direkte Links zu fehlenden MS-Sicherheitsupdates angeboten.

Das Werkzeug gibt es zurzeit nur in englischer Sprache. Den Baseline Security Analyzer finden Sie hier:
http://www.microsoft.com/technet/security/tools/mbsahome.asp
IE mit Google aufrüsten
Google für die IE-Suchleiste:
Ein Klick auf die IE-Schaltfläche 'Suchen' ruft standardmäßig das MSN Web-Search-Formular auf. Es geht aber auch anders: Wer die Suchmaschine Google bevorzugt, kann sie Anhand dieser herunterladbaren REG-Datei als Standard-Suchleiste im Internet Explorer einbinden.

Speichern Sie die Datei degoogle.reg über die rechte Maustaste mit "Ziel Speichern unter...". Anschliessend können Sie per Doppelklick auf 'degoogle.reg' die Informationen der Systemregistrierung hinzufügen. Beim nächsten Browserstart erscheint das Google-Suchformular im IE-Suchfenster.
Google-Suche von der IE-Adreßzeile:
Sie können die Google-Suchmaschine auch direkt von der IE-Adreßzeile aufrufen. Dazu benötigen Sie das kostenlose Tweak-UI-Powertoy - Artikel und Download hier.
Starten Sie Tweak UI und finden Sie den Abschnitt 'Internet Explorer --> Search --> Search Prefixes'.
http://www.google.com/search?q=%s ein.

Beim nächsten Start von Internet Explorer können Sie in der Browser-Adreßzeile gg Suchbegriff eingeben, um den Suchbegriff direkt von Google recherchieren zu lassen.
Warnung vor unsignierten Treibern deaktivieren
Derzeit sind Gerätetreiber, die über eine offizielle Zertifizierung von Microsoft verfügen, deutlich in der Minderheit. Beim Versuch, einen nicht-signierten Treiber unter XP einzubinden, meckert das Betriebssystem mit einem Warnhinweis. Wer dieses nützliche - aber für versierte Anwender oft lästige - Feature deaktivieren möchte, kann folgende Einstellung vornehmen:

Nach dem nächsten Neustart tritt die Option in Kraft.
Media Player Mediendatenbank löschen und reparieren
Windows Media Player erfasst abgespielte und eingelesene Mediendateien in einer eigenen Medienbibliothek. Werden diese Mediendateien auf der Festplatte verschoben, enthält die Medienbibliothek ungültige Verweise auf die ursprünglichen Speicherorte. Abhilfe: Löschen Sie die vorhandene Medienbibliothek und lassen Sie den Media Player eine neue Datenbank erstellen.

C:\Dokumente und Einstellungen\All Users\
Anwendungsdaten\Microsoft\Media Index
Mit diesem Schritt löschen Sie nur die Media-Player-Datenbank - die Mediendateien bleiben natürlich unversehrt.
Taskleiste: Gruppierungsverhalten anpassen
Wenn drei oder mehr Instanzen des gleichen Programms geöffnet sind, werden diese in der Taskleiste zusammengefasst und in einer Gruppe angezeigt. So wird Platz eingespart, und das Auffinden des gesuchten Programmfensters erheblich vereinfacht.
Auch dieses Verhalten lässt sich mit Hilfe eines Registry-Eingriffs anpassen.
Starten Sie den Registrierungseditor über 'Start - Ausführen - regedit'
Folgender Wert in der Registry bestimmt, ab wievielen Programminstanzen die Taskleisten-Gruppierung aktiviert wird:
HKEY_CURRENT_USER\Software\Microsoft\Windows\
CurrentVersion\Explorer\Advanced\
TaskbarGroupSize
Der voreingestellte Wert ist 3. Soll die Gruppierung beispielsweise erst ab 5 Programminstanzen aktiviert werden, ändern Sie den Wert auf 5.

Wer es einfacher mag: Die hier herunterladbare REG-Datei (taskleiste5.reg) ändert die Aktivierung der Taskleisten-Gruppierung auf 5 Programminstanzen. Speichern Sie die Datei über die rechte Maustaste mit "Ziel Speichern unter...". Anschliessend können Sie per Doppelklick auf die REG-Datei die Informationen der Systemregistrierung hinzufügen.
Diese REG-Datei (taskleiste3.reg) stellt die Standardeinstellung von '3' wieder her.
Programme an das Startmenü anheften
Häufig verwendete Programme lassen sich an das Startmenü anheften, so dass sie stets schnell zur Verfügung stehen. Klicken Sie dazu im Startmenü mit der rechten Maustaste auf das gewünschte Programm-Icon und wählen Sie den Menüpunkt "An Startmenü anheften". Dies funktioniert auch im Windows Explorer mit beliebigen .EXE-Dateien. Einmal angeheftete Programme können über die rechte Maustaste mit dem gleichnamigen Menüpunkt vom Startmenü wieder gelöst werden. Beides funktioniert nur mit dem neuen XP-Startmenü - nicht aber mit dem klassischen Startmenü.

Domänenzugriff mit XP Home Edition
Die Anmeldung an Windows 2000 oder NT Netzwerk-Domänen bleibt der Professional-Version von Windows XP vorbehalten. XP Home Edition bleibt aussen vor. Mit einem Trick jedoch zeigt auch XP Home Edition Domänenressourcen an, und mit entsprechenden Berechtigungen kann auf diese zugegriffen werden.

Wie der Trick funktioniert zeigt Ihnen dieser ZDNet-Artikel. (öffnet in neuem Fenster)
Einbruchsversuche protokollieren
Die nötige Einstellung finden Sie in der Systemsteuerung unter Verwaltung > Lokale Sicherheitsrichtlinien > Lokale Richtlinien > Überwachungsrichtlinien.
Aktivieren Sie unter "Anmeldeversuche überwachen" die Option "Fehlgeschlagene Versuche überwachen".
Die Ergebnisse der Überwachung finden Sie in der Windows-Ereignisanzeige.
Komplette Referenz aller Windows-Tastenkombinationen
Viele Befehle lassen sich ohne Maus schneller ausführen: Eine komplette Referenz aller Windows XP Tastaturkürzel und Tastenkombinationen ist in der Windows-Hilfedatei keyshort.chm enthalten.

Schnellzugriff:
Start - Ausführen -
C:\Windows\Help\keyshort.chm
Ungelesene Nachrichten am Anmeldebildschirm deaktivieren
Wer die Anzeige von ungelesenen Nachrichten am Anmeldebildschirm deaktivieren möchte, kann folgenden Eingriff in der Systemregistrierung vornehmen:
Starten Sie den Registrierungseditor über
'Start - Ausführen - regedit'
Navigieren Sie zu dem Zweig
HKEY_CURRENT_USER\Software\Microsoft\
Windows\CurrentVersion\UnreadMail
In der rechten Fensterhälfte finden Sie den Schlüssel 'MessageExpiryDays'
Setzen Sie den Wert auf '0' um die Anzeige ungelesener Nachrichten am Anmeldebildschirm zu verhindern.

Eigene Bildschirmschoner erstellen
Windows XP bietet im Lieferumfang ein einfaches Werkzeug zum Erstellen eigener Diashow-Screensaver. Zu finden ist das Tool in der Systemsteuerung unter
'Anzeige - Bildschirmschoner -
(Auswahlliste) Diashow eigener Bilder'

Mit einem Klick auf die Schaltfläche 'Einstellungen' läßt sich das Screensaver-Modul konfigurieren.
Dateiserien schnell umbenennen
Eine wenig bekannte Neuerung im Windows Explorer ist die Möglichkeit, mehrere Dateien in einem Rutsch umzubenennen.

Wählen Sie alle umzubennenden Dateien aus, und klicken Sie mit der rechten Maustaste auf die erste Datei der Dateiserie. Wählen Sie den Menüpunkt 'Umbenennen' und geben Sie der Datei den gewünschten Namen. Alle ausgewählten Dateien werden nun mit dem eingegebenen Dateinamen zusätzlich aufsteigender Numerierung umbenannt.
XP mit eigenem Markenzeichen versehen
Legen Sie mit diesem Tipp einen personalisierten Eintrag im XP-Startmenü an, wie Sie oft bei vorinstallierten OEM-Versionen von XP zu finden sind. So erscheint direkt unter "Ausführen" ein Icon und Text Ihrer Wahl, beim Klick auf den Eintrag kann eine URL oder eine Anwendung aufgerufen werden. Gehen Sie folgendermaßen vor:
1. Erstellen Sie mit dem Texteditor eine .REG-Registrierungsdatei namens markenzeichen.reg mit folgendem Inhalt:
2. Passen Sie die REG-Datei an. Ersetzen Sie beide Instanzen von IHR TEXT mit dem Text, der im Startmenü erscheinen soll. Ersetzen Sie die eine Instanz von BEFEHL mit dem Befehl, der ausgeführt werden soll. Soll beispielsweise eine URL aufgerufen werden, tragen Sie hier die URL ein, etwa "Param1"="http://winxp.zdnet.de". Sie können hier aber auch Anwendungen Starten oder lokale Dokumente öffnen.
3. Erstellen Sie ein Icon mit 24x24 Pixeln und speichern Sie es im WINDOWS-Verzeichnis ab. Ersetzen Sie gegebenenfalls in der REG-Datei "icon.ico" mit dem Namen Ihres Icons.
4. Speichern Sie Ihre Änderungen in markenzeichen.reg ab. Mit einem Doppelklick auf markenzeichen.reg werden die Informationen der Registrierung hinzugefügt. Beim nächsten Neustart von Explorer erscheint Ihr personalisierter Eintrag im Startmenü.
Unser Beispiel können Sie hier direkt herunterladen.

Laufwerke über das Kontextmenü defragmentieren
Mit diesem Tipp können Sie Laufwerke über bequem über das Windows-Explorer-Kontextmenü defragmentieren.

Erstellen Sie eine Datei defrag.inf mit folgendem Inhalt:
Klicken Sie mit der rechten Maustaste auf defrag.inf und wählen Sie den Menüpunkt "Installieren". Nun steht Ihnen im Laufwerk-Kontextmenü der Befehl "Defragmentieren" zur Verfügung.
Um den Eintrag aus dem Kontextmenü wieder zu entfernen, navigieren Sie mit RegEdit zum Eintrag HKEY_CLASSES_ROOT\Drive\shell\ und löschen Sie hier den Ordner "Defragmentieren"
Freigegebene Ordner von Arbeitsplatzansicht entfernen
Standardmäßig zeigt Windows Explorer unter "Arbeitsplatz" und "Auf diesem Computer gespeicherte Daten" eine Liste aller freigegebenen Ordner an.
Wer diese Verknüpfungen nicht benutzt, oder zwecks Übersichtlichkeit aus dieser Ansicht entfernen möchte, kann folgende Änderung an der Registry vornehmen:
Starten Sie den Registrierungseditor regedt32.exe
Navigieren Sie zu dem Zweig
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\
Windows\CurrentVersion\Explorer\
My Computer\NameSpace\DelegateFolders
und löschen Sie hier den Schlüssel
{59031a47-3f72-44a7-89c5-5595fe6b30ee}.
Systemdateien regelmäßig überprüfen
Überprüfen Sie in regelmäßigen Zeitabständen Ihre geschützten Windows-XP-Systemdateien mit dem System File Checker sfc. Findet das Programm korrupte oder falsche Versionen, ersetzt es diese mit Originalversionen von der Installations-CD. Halten Sie die CD also bereit.
Optionen:
sfc /?
Zeigt sfc Optionen an
sfc /scannow
Überprüft sofort alle geschützten Systemdateien
sfc /scanonce
Überprüft alle geschützten Systemdateien einmal beim nächsten Neustart
sfc /scanboot
Überprüft alle geschützten Systemdateien bei jedem Start
sfc /revert
Setzt Scan auf die Standardeinstellungen zurück
sfc /purgecache
Leert den Dateicache
DLLs aus dem Speicher entladen
Standardmäßig behält Windows XP die von Anwendungen benötigten DLLs im Speicher, nachdem die dazugehörige Anwendung beendet wurde. Für Systeme mit weniger großzügigen RAM-Ausstattung oder in Arbeitsumgebungen wo XP längere Zeit ohne Neustart auskommen muss, ist es ratsam, dem System anzuweisen, DLLs nach Beenden von Anwendungen sofort zu entladen.
Dies erreicht man mit folgendem Eingriff in die Registry:
Starten Sie den Registrierungseditor regedt32.exe
Navigieren Sie zu
HKEY_LOCAL_MACHINE\SOFTWARE\
Microsoft\Windows\CurrentVersion\
Explorer
Erstellen Sie hier in der rechten Fensterhälfte eine neue Zeichenfolge (rechte Maustaste > Neu > Zeichenfolge) mit dem Namen AlwaysUnloadDll. Klicken Sie jetzt auf AlwaysUnloadDll, geben Sie den Wert 1 ein, und klicken Sie auf OK.

Programm- und Webseitenaufruf von der Taskleiste
Fügen Sie der Taskleiste das Adressen-Eingabefeld hinzu, um von dort aus Programme und Webseiten direkt aufrufen zu können. Nutzen Sie dieses Eingabefeld anstelle des "Ausführen"-Dialogs.
Um das Adressen-Eingabefeld auf der Taskleiste zu aktivieren, klicken Sie mit der rechten Maustaste auf die Taskleiste und wählen Sie "Symbolleisten" > "Adresse".

Komplette Befehlszeilenreferenz per Mausklick
So steht Ihnen eine praktische XP-Befehlszeilenreferenz schnell zur Verfügung: Erstellen Sie eine Verknüpfung mit
hh.exe ms-its:C:\WINDOWS\Help\ntcmds.chm::/ntcmds.htm

Detailinformationen im Gerätemanager aktivieren
Wer im Gerätemanager erweiterte Geräteinformationen erhalten möchte, kann unter
Systemsteuerung > System > Erweitert > Umgebungsvariablen
folgende neue Systemvariablen hinzufügen:
Name:
Devmgr_show_details
Wert:
1
Ein neuer Reiter mit erweiterten Geräteinformationen erscheint im Gerätemanager.
Name:
Devmgr_show_nonpresent_device
Wert:
1
Der Gerätemanager zeigt nun auch Informationen zu in der aktuellen Konfiguration nicht vorhandenen Geräten an.


Windows XP Updates lokal speichern
Das eigens für Firmenkunden vorgesehene Corporate Windows Update erlaubt es, Updates gezielt herunterzuladen und in einem frei wählbaren Ordner zu speichern. Zusätzlich zu den Update-Installationsdateien erhalten Sie Links zu weiterführenden Informationen der Microsoft Knowledge Base.

Das deutsche Corporate Windows Update finden Sie hier:
http://v4.windowsupdate.microsoft.com/
de/default.asp?corporate=true
Schnellzugriff auf XP System- und Konsolenutilities
Verschaffen Sie sich schnellen Zugriff auf alle integrierten System- und Konsolen-Utilities. Erstellen Sie einen Ordner in Ihrem Startmenü mit Verknüpfungen zu folgenden Tools in WINDOWS\System32:
cleanmgr.exe - Datenträgerbereinigung
cmd.exe - Eingabeaufforderung
dxdiag.exe - DirectX-Diagnoseprogramm
regedt32.exe - Registrierungs-Editor
taskmgr.exe - Task-Manager
certmgr.msc - Zertifikat-Manager
ciadv.msc - Indexdienst
compmgmt.msc - Computerverwaltung
diskmgmt.msc - Datenträgerverwaltung
devmgmt.msc - Geräte-Manager
dfrg.msc - Defragmentierung
eventvwr.msc - Ereignisanzeige
fsmgmt.msc - Freigegebene Ordner
gpedit.msc - Gruppenrichtlinien-Editor
lusrmgr.msc - Lokale Benutzer und Gruppen
ntmsmgr.msc - Wechselmedienverwaltung
perfmon.msc - Leistungsmonitor
secpol.msc - Sicherheitseinstellungen
services.msc - Diensteverwaltung
comexp.msc - Komponentendienste
Arbeitsstation per Mausklick sperren
Um Ihre Arbeitsstation mit einem Mausklick zu sperren, erstellen Sie eine neue Verknüpfung, und geben Sie im Textfeld "Speicherort des Elements" folgenden Befehl ein:
rundll32.exe user32.dll,LockWorkStation
Persönliche Nachricht beim Booten anzeigen
Wer beim Booten von XP ein persönliches Hinweisfenster anzeigen lassen möchte, bearbeitet folgende Registry-Schlüssel:
Titel des Hinweisfensters:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\
Windows NT\CurrentVersion\Winlogon\
LegalNoticeCaption
Nachrichtentext:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\
Windows NT\CurrentVersion\Winlogon\
LegalNoticeText
Internet Explorer 6: Schriftartengröße schnell umstellen
Wenn Sie eine Radmaus haben, können Sie im IE6-Browser die angezeigte Schriftartengröße schnell anpassen. Halten Sie die STRG-Taste gedrückt, und scrollen Sie mit dem Mausrad nach vorne oder nach hinten, um die Schriftarten zu vergrößern oder zu verkleinern.
Klassiche Windows-2000-Anmeldung verwenden
Wer die klassische Windows-2000-Anmeldung bevorzugt, kann diese leicht wieder einstellen. Klicken Sie in der Systemsteuerung auf Benutzerkonten, wählen Sie "Art der Benutzeranmeldung ändern" und deaktivieren Sie hier den Punkt "Willkommensseite verwenden".
Schneller Systemzugriff von der Taskleiste
So erstellen Sie auf der Taskleiste ein neues Menü für schnellen Zugriff auf das gesamte System:
Klicken Sie mit der rechten Maustaste auf die Taskleiste und wählen Sie Symbolleisten > Neue Symbolleiste. hier wählen Sie "Arbeitsplatz" und klicken Sie auf OK.

XP-Bildbetrachter deaktivieren
Windows XP zeigt per Voreinstellung Bilddateien mit seinem integrierten Bildbetrachter an. Möchten Sie diese Funktionalität ausschalten, um einen anderen Grafikviewer zu verwenden, löschen Sie folgenden Registry-Schlüssel:
HKEY_CLASSES_ROOT\SystemFileAssociations\
image\ShellEx\ContextMenuHandlers\
ShellImagePreview
Bootvorgang optimieren
Ein effektives Werkzeug zur XP-Optimierung ist das Boot-Analyse-Tool BootVis. Das Programm analysiert den Startvorgang von Windows XP, und beinhaltet eine Optimierungsfunktion, die alle Dateien, die das System zum Starten benötigt, neu auf der Festplatte auslegt. Nach der Optimierung werden in der Regel einige Sekunden beim Hochfahren des Rechners eingespart.

Anleitung:
1. Download BootVis.
2. Starten Sie das Programm BootVis.exe.
3. Wählen Sie im Menü Trace den Befehl Next Boot + Driver Delays.
4. Standardwerte beibehalten, OK klicken.
5. Das System wird neu gestartet.
6. Nach dem Neustart macht sich BootVis ans Werk. Tun Sie nichts, bis BootVis die Resultate seiner Analyse anzeigt. Dies kann bis zu einer Minute dauern.
7. Die vertikale Linie in den Diagrammen zeigt die Dauer des Bootvorgangs an. Weitere Informationen zu CPU, Treiber und Prozesse finden Sie in den entsprechenden Abschnitten.
8. Wählen Sie nun im Menü Trace den Befehl Optimize System
9. Das System wird neu gestartet.
10. Nach dem Neustart optimiert BootVis die Auslegung der Startdateien.
Überflüssige Dienste deaktivieren
Zugunsten einer universalen Standardkonfiguration nimmt XP Performance-Einbußen in Kauf. Nicht benötigte Dienste werden beim Systemstart automatisch aktiviert, und bremsen das System aus. Welche Dienste Sie bedenkenlos deaktivieren können, lesen Sie in diesem Artikel. (öffnet in neuem Fenster)

Internet Explorer 6 Index.dat löschen
Internet Explorer benutzt ein ausgeklügeltes System zum Verwalten der temporären Internetdateien, das alle heruntergeladenen Webseiten und dazugehörigen Dateien nicht nur lokal speichert, sondern diese auch indiziert.
Diese Indizierung, gespeichert in der versteckten Datei index.dat, ermöglicht dem Browser schnelleren Zugriff auf lokal gespeicherte Internet-Dateien, wenn diese aus dem Cache aufgerufen werden. Was nicht jeder weiss: Auch wenn die temporären Internetdateien mit den im Browser dafür vorgesehenen Funktionen komplett gelöscht werden, bleiben eindeutige Spuren der besuchten Webseiten in der index.dat erhalten. Interessierte User können sich somit anhand der index.dat ein klares Bild über Ihr Surfverhalten verschaffen.
Wie Sie die Index.dat unter XP spurlos beseitigen, erfahren Sie in diesem Artikel. (öffnet in neuem Fenster)

Klassisches Windows-Erscheinungsbild wiederherstellen
Die neue Benutzeroberfläche von Windows XP ist Geschmackssache. Wer das klassische Erscheinungsbild früherer Windows-Versionen bevorzugt, kann dieses mit wenigen Mausklicks wiederherstellen. In der Systemsteuerung unter Anzeige finden Sie den Menüreiter "Designs". Hier steht neben weiteren XP-Motiven auch das klassiche Windows-UI zur Auswahl. Auch das bekannte Startmenü kann aktiviert werden. Klicken Sie im neuen Startmenü mit der rechten Maustaste auf eine leere Fläche und dann auf Eigenschaften. Hier können Sie das "klassische" Startmenü auswählen und mit dem Button "Anpassen" erweiterte Optionen einstellen.

Auslagerungsdatei löschen
Die von Windows angelegte Auslagerungsdatei des virtuellen Arbeitsspeichers kann unter Umständen sensible Daten enthalten, die später von neugierigen Personen eingesehen werden können. Sicherheitsbewusste Anwender können eine Einstellung vornehmen, die Windows befiehlt, Inhalte der Auslagerungsdatei beim Herunterfahren des Systems zu löschen.
Dazu führen Sie folgende Menübefehle aus:
Start -> Einstellungen -> Systemsteuerung -> Verwaltung -> Lokale Sicherheitsrichtlinie -> Lokale Richtlinien -> Sicherheitsoptionen
Hier können Sie die Option "Herunterfahren: Auslagerungsdatei des virtuellen Arbeitsspeichers löschen" aktivieren.
Temporäre Internetdateien löschen
Der Internet Explorer 6 löscht beim Schließen des Browsers Ihre temporären Internetdateien, allerdings nur, wenn Sie die entsprechende Option im Browser aktivieren. Im Menü
Extras -> Internetoptionen -> Erweitert -> Sicherheit
finden Sie den Eintrag Leeren des Ordners Temporary Internet Files beim Schließen.
Des Weiteren sollten Sie den Eintrag Verschlüsselte Seiten nicht auf der Festplatte speichern aktivieren.
Ruhezustand-Option beim Herunterfahren anzeigen
Die Option, den Rechner in den Ruhezustand zu versetzen, wird im Computer-Ausschalten-Dialog standardmäßig nicht angezeigt. Drücken Sie während des Computer-Ausschalten-Dialogs einfach die Umschalttaste (Shift), um die Ruhezustand-Option erscheinen zu lassen.
Unerwünschte Windows-Komponenten deinstallieren
In älteren Windows-Versionen konnten über das Software-Applet in der Systemsteuerung eine Vielzahl von Windows-Komponenten hinzugefügt oder entfernt werden. Windows XP hingegen versteckt in der Default-Einstellung Komponenten wie beispielsweise den Windows Messenger, so dass diese sich nur mit einem kleinen Trick deinstallieren lassen.
Zunächst übernehmen Sie folgende Änderungen im Windows Explorer, falls noch nicht eingestellt:
Extras -> Ordneroptionen -> Ansicht
Bei "Erweiterungen bei bekannten Dateitypen ausblenden" und "Geschützte Systemdateien ausblenden (empfohlen)" entfernen Sie die Häkchen. Bei "Inhalte von Systemdateien anzeigen" das Häkchen setzen. Mit der Schaltfläche "Für alle Übernehmen" machen Sie die Änderungen für alle Ordner wirksam.
Navigieren Sie nun mit dem Windows Explorer in das Verzeichnis c:\windows\inf und suchen Sie die Datei sysoc.inf. Diese Datei enthält Setup-Informationen über installierte Windows-Komponenten. Über die rechte Maustaste und "Öffnen mit" öffnen Sie sysoc.inf mit dem Editor.
Software-Einträge mit dem Wort "Hide" werden beim Hinzufügen oder Entfernen von Windows-Komponenten über die Systemsteuerung nicht angezeigt. Um diese Einträge wieder sichtbar zu machen, starten Sie mit STRG + H die Funktion Suchen und Ersetzen. Suchen Sie nach ,hide, und ersetzen Sie es durch ,, (zwei Kommata ohne Leerzeichen). Speichern Sie Ihre Änderungen und starten Sie den Computer neu. Nun zeigt das Software-Applet in der Systemsteuerung alle zur Zeit installierten Windows-Komponenten an, und erlaubt es, diese zu entfernen.

Mehr freier Festplattenspeicher
Windows XP belegt nach einer Default-Installation rund 1,5 GByte Festplattenspeicher. Wem das zu viel ist, der kann mit den folgenden Schritten einige hundert MByte gewinnen.
Ruhezustand deaktivieren:
Die
Ruhezustand-Funktion von XP legt die Datei hiberfil.sys im Root der
Systempartition an, die je nach Systemeinstellung eine Größe von
einigen hundert MByte besitzen kann. Wer die Ruhezustand-Funktion nicht
benötigt, kann sie mit folgendem Menübefehl deaktivieren und so diesen
Festplattenspeicher zurückgewinnen:
Start -> Systemsteuerung -> Energieoptionen -> Ruhezustand -> Häkchen entfernen bei "Ruhezustand aktivieren"
Systemwiederherstellung deaktivieren:
Die
XP-Systemwiederherstellung raubt im Lauf der Zeit eine beträchtliche
Menge an Festplattenspeicher. Wer auch ohne diese Funktion auskommt,
kann sie mit folgendem Menübefehl deaktivieren:
Start -> Systemsteuerung -> System -> Systemwiederherstellung -> Systemwiederherstellung
auf allen Laufwerken deaktivieren (Häkchen setzen). Diese Einstellung sollte nur von versierten Anwendern übernommen werden.
Utility zur Datenträgerbereinigung:
Zu
guter Letzt können Sie mit dem Windows-eigenen
Datenträgerbereinigungs-Utility überflüssige Dateien löschen. Wählen
Sie das zu reinigende Laufwerk aus und aktivieren Sie die gewünschten
Optionen. Das Tool finden Sie unter
Start -> Programme -> Zubehör -> Systemprogramme -> Datenträgerbereinigung
Priorität von Prozessen festlegen
Wer mit mehreren Applikationen gleichzeitig arbeitet, kann unter XP festlegen, mit welcher Priorität diese laufen sollen. Die Performance einzelner Programme kann mit diesem manuellen Eingriff merklich gesteigert werden. Dies ist beispielsweise beim Kodieren von Video- oder Audiodaten sinnvoll, oder bei anderen Anwendungen mit hohen Systemanforderungen.
Wechseln Sie mit STRG-ALT-ENTF in den Windows Task Manager. Der Reiter "Prozesse" listet alle derzeit laufenden Prozesse auf. Über die rechte Maustaste lässt sich die Priorität des ausgewählten Prozesses mit dem gleichnamigen Menüpunkt auf eine von sechs Stufen festlegen.
Integrierte ZIP-Funktionalität ausschalten
Windows XP kann ohne Zusatzsoftware wie WinZip oder WinRAR mit ZIP-Archiven umgehen. Im Windows Explorer werden ZIP-Archive wie normale Verzeichnisse behandelt, und das Extrahieren und Hinzufügen von Dateien erfolgt wie bei gewöhnlichen Ordnern. Das ist eine nette Zusatzfunktion, vorausgesetzt, Sie verfügen über einen schnellen Rechner. Auf langsameren PCs erweist sich die integrierte ZIP-Funktion als Performance-Bremse.
Anwender mit langsameren Rechnern sollten erwägen, die ZIP-Funktion mit folgendem Befehl in der Eingabeaufforderung zu deaktivieren:
regsvr32 /u zipfldr.dll
Sollten Sie es sich später anders überlegen, stellen Sie die Funktion mit dem Befehl
regsvr32 zipfldr.dll
wieder her.
Windows XP Powertoys
Für Windows XP hat Microsoft ein neues, kostenloses Powertoys-Paket zusammengeschnürt. Neben einer neuen, XP-spezifischen Version des TweakUI-Konfigurationstools sind folgende Anwendungen im Installer enthalten: Fast User Switcher, Powertoy Calculator, ALT-TAB Replacement, Virtual Desktop Manager, Phototoys, Command Window on Folder, Slideshow Generator, Maginifier, HTML Slideshow Generator und Timershot.
Mehr Informationen zu den einzelnen Powertoys und Download finden Sie hier.

Programme als anderer Benutzer ausführen
Unter XP können Sie Anwendungen während einer aktiven Sitzung mit einem anderen Benutzerkonto ausführen, ohne sich zuvor abmelden und neu anmelden zu müssen. Dies ist praktisch, wenn ein bestimmtes Programm als Administrator ausgeführt werden muss, Sie aber nicht als solcher angemeldet sind.
Suchen Sie im Windows Explorer die Anwendung die ausgeführt werden soll, und wählen Sie über die rechte Maustaste den Menüpunkt "Ausführen als".

Gruppenrichtlinien-Editor
Neben den Windows XP Powertoys können sich Tweaker mit dem in der XP-Pro-Version enthaltenen Gruppenrichtlinien-Editor (GPEDIT.msc) vergnügen. Wie der Name vermuten läßt, handelt es sich hierbei um eine Kommandozentrale zum Verwalten von Computer- und Benutzerkonfigurationen, Softwareeinstellungen, Windows-Einstellungen und administrativen Vorlagen. Betrachten Sie GPEDIT als ein TweakUI für Fortgeschrittene.
Das Power-Tool finden Sie unter
C:\WINDOWS\system32\gpedit.msc

Ordner für Musikverzeichnisse gestalten
Wer ganze Musik-CDs im MP3- oder WMA-Format in eigene Ordner auf der Festplatte gespeichert hat, kann im Windows Explorer die dazugehörigen CD-Cover anzeigen lassen. Speichern Sie hierzu in dem entsprechenden Ordner eine Bilddatei im JPG-Format ab und benennen sie diese Datei folder.jpg. Wechseln Sie nun im Menü "Ansicht" in die Miniaturansicht und schon zeigt Explorer für jedes Verzeichnis die von Ihnen gewählte Cover-Grafik an.
Auch Windows Media Player verwendet die Grafik bei der Wiedergabe, wenn die Visualisierung "Albumcover" ausgewählt ist.

Windows Explorer Detailansicht
Der XP Windows Explorer kann weitaus mehr Detail anzeigen als seine Vorgänger. Insbesondere Multimedia-Informationen haben ihren Weg in den Dateimanager gefunden: Interpret, Albumtitel, Genre, Bitrate, Kameramodell, Abmessungen und mehr können in der Explorer-Detailansicht angezeigt werden. Führen Sie hierzu im Windows Explorer folgenden Menübefehl aus:
Ansicht -> Details (Häkchen setzen)
Anschließend müssen Sie in der rechten Fensterhälfte mit der rechten Maustaste auf den Info-Balken mit Name, Größe, Typ klicken. Nun erhalten Sie ein weiteres Menü, in dem Sie die angezeigten Eigenschaften anpassen können.

Windows Explorer Gruppenanzeige
Um im Windows Explorer alle in einem Verzeichnis enthaltenen Dateien in übersichtlichen, nach Buchstaben geordneten Gruppen anzeigen zu lassen, führen Sie folgenden Menübefehl aus:
Ansicht -> Symbole anordnen nach -> In Gruppen anzeigen (Häkchen setzen)

Windows Explorer in Ordner Ihrer Wahl starten
Ein für viele Anwender frustrierendes Feature - Windows Explorer startet von Haus aus im Ordner "Eigene Dateien". Mit folgendem Trick können Sie eine Verknüpfung mit Windows Explorer auf dem Desktop anlegen, die beim Aufruf einen Ordner Ihrer Wahl anzeigt. In diesem Beispiel soll Explorer beim Start den Ordner C:\Programme anzeigen.
Klicken Sie mit der rechten Maustaste auf den Desktop und wählen Sie Neu -> Verknüpfung. Im Textfeld "Geben Sie den Speicherort des Elements an", geben Sie folgende Befehlszeile ein:
%SystemRoot%\explorer.exe /n,/e,C:\Programme
Klicken Sie nun auf "Weiter", geben Sie der Verknüpfung einen Namen Ihrer Wahl, und klicken Sie auf "Fertig stellen", um den Vorgang zu beenden. Sollten Sie zu einem späteren Zeitpunkt den Zielordner der Verknüpfung ändern wollen, können Sie die Eigenschaften der Verknüpfung abermals über die rechte Maustaste modifizieren.

Lautstärkeregelung anzeigen
Seltsamerweise versteckt Windows XP standardmäßig die Lautstärkeregelung - das Lautsprechersymbol ist von der Taskleiste verschwunden. Verschaffen Sie sich den gewohnten Zugriff mit folgender Einstellung:
Start -> Einstellungen -> Systemsteuerung -> Sounds und Audiogeräte -> Lautstärkeregelung in der Taskleiste anzeigen.
Windows XP Tastaturkürzel
Verzichten Sie auf Ihre Maus. In XP stehen Ihnen eine ganze Reihe nützlicher Tastaturkürzel zur Verfügung:
Windows-Taste: Startmenü anzeigen
Windows + D: Alle Fenster minimieren oder wiederherstellen
Windows + E: Windows Explorer öffnen
Windows + F: Suchen-Dialog anzeigen
Windows + STRG + F: Suche nach Computern anzeigen
Windows + F1: Hilfe- und Supportcenter anzeigen
Windows + R: Ausführen-Dialog anzeigen
Windows + Pause: Systemeigenschaften anzeigen
Windows + L: PC Sperren
Windows + U: Hilfsprogramm-Manager öffnen
Windows + Q: Benutzer wechseln
Weitere Artikel: XP Tipps, Tricks und Tuning
Windows XP Tuning
BIOS-Tuning Windows XP
Mehr Performance, höhere Stabilität: Ohne ein optimal eingestelltes Bios, bleibt ein Großteil der Leistung auf der Strecke.
Windows XP Downloads
Windows XP Power-Tools
Windows
XP lässt sich in vielerlei Hinsicht individuell anpassen und
optimieren. Hierfür gibt es mittlerweile auch einige Tools, die solche
Änderungen und Eingriffe ins System vereinfachen.
Windows XP
Neue Version: Powertoys für Windows XP
Unverzichtbare
Konfigurationstools, nützliche Systemerweiterungen und nette
Bonus-Anwendungen: Microsofts neue Powertoys stellen alle bisherigen
Versionen in den Schatten.
Windows XP Kaufberatung
Optimale Hardware für Windows XP
Komplettangebote
im Handel sind zwar häufig sehr billig. Die Hardware-Ausstattung
unterliegt meistens dem Preisdiktat und kann nur selten als optimal
bezeichnet werden. Häufig sind deshalb Kompatibilitätsprobleme mit
Windows XP vorprogrammiert.
Windows XP Privacy
XP Schnüffeldienste deaktivieren
Windows
XP nimmt nicht nur bei der Produktaktivierung gern Kontakt mit
Microsoft auf. Die Nähe und enge Anbindung des Betriebssystems zum
Software-Riesen sorgen bei Anwendern für Unbehagen.
Windows XP
Mehr Performance für Windows XP
Zugunsten
der Kompatibilität, des Komforts und der Universalität nehmen die
Standardeinstellungen von Windows XP Leistungseinbußen in Kauf. Durch
das Deaktivieren überflüssiger Dienste, Ausschalten von visuellen
Nettigkeiten und Optimieren des Boot-Vorgangs gewinnt XP an
Performance.
Windows XP Privacy
Internet Explorer und WinXP: Verhängnisvolle index.dat
Internet
Explorer erstellt auf jedem System einen Index aller besuchten
Webseiten. Auch wenn die Temporären Internetdateien komplett gelöscht
werden, kann anhand dieses Indexes der Webseitenverlauf einfach
rekonstruiert werden.
Windows XP
Domänenzugriff mit XP Home Edition
Die
Anmeldung an NT oder 2000 Netzwerk-Domänen bleibt der
Professional-Version von Windows XP vorbehalten. Doch mit einem Trick
zeigt auch XP Home Edition Domänenressourcen an, und mit entsprechenden
Berechtigungen kann auf diese zugegriffen werden.
XP-Tuning
Anmelde-Bildschirm für Windows XP im Eigenbau
Mit ein paar Tricks lässt sich der Anmelde-Bildschirm von Windows XP verändern.
Windows XP Tuning
Nvidia und VIA bremsen XP
Neue Treiber von Nvidia und VIA verlängern Start- und Shutdown-Zeit von Windows XP beträchtlich.
Windows XP Performance
Performance-Analyse: Windows XP Final
Neben
vielen neuen Features von Windows XP ist vor allem auch die Performance
des neuen Betriebssystems von großem Interesse. ZDNet TechExpert führt
einen Performancevergleich zu Windows 2000, Windows NT und Windows 98SE
durch.
Windows XP
ISO Recorder Power Toy
Das
kostenlose Tool für Windows XP ergänzt die im Betriebssystem
integrierten CD-Brennfunktionen und ermöglicht das einfache Klonen von
CDs. Mit wenigen Mausklicks kopiert das Windows-XP-Add-On ganze CDs als
ISO-Image auf die Festplatte und brennt Sie anschliessend auf CD.
Copyright
1997 - 2006 CNET Networks Deutschland GmbH bzw. CNET Networks Inc. Alle
Rechte vorbehalten. Vervielfältigung im Ganzen oder in Teilen ist ohne
ausdrückliche Genehmigung von CNET in jeglicher Form auf jedem Medium
verboten. ZDNet und das ZDNet-Logo sind Warenzeichen der CNET Networks,
Inc. ZDNet ist nicht verantwortlich für die Inhalte externer Websites.