Unable to Connect to the Database: Could Not Connect to MySQL ! https://www.akeebabackup.com/documentation/troubleshooter/abidatabase.html I can't restore my database, or receive AJAX Error, timeout or other errors while restoring my database with ANGIE Let's try some common troubleshooting steps. In 100% of cases we've seen (yes, we really do mean all of them) it's one of the following. If you are not restoring on the same host as the one you backed up from, if you are transferring a site from a live server to a local server or if you are transferring a site from a local server to a live server you need to ensure the following: You MUST create a new database BEFORE trying to restore your database. ANGIE can not create a new database unless you are restoring on a local host and using the root credentials. In other words, almost never. As a rule of thumb: always create a database before restoring your site. There are instructions for creating a new database below. If you are on a cPanel host you have to add the user to the database. Consult your host's documentation about that. You MUST supply the database connection information of your new host BEFORE clicking on the Next button. ANGIE will present you with the database connection information of the site you backed up from. These are no longer valid on the new host and you MUST supply the new host's database connection information. Further to that you DO NOT have to create databases and users on the new to match your old site's information. This is usually the extremely hard way to go. Simply, type in the new host's database connection information in ABI's interface BEFORE clicking on the "Next" button. etc. ------------ https://docs.joomla.org/Unable_to_connect_to_the_database The Most Common Reasons Sometimes you will see this message if MySQL/MariaDB has stopped running on your server. Your server administrator may temporarily shut down MySQL/MariaDB to perform maintenance. In such circumstances, your site will likely return shortly. Your database user has been deleted. If this is the case, you will need to recreate your database user with the same username and password that existed when you first installed Joomla. Use your domain control panel to administer this or contact your server administrator. Your database username or password has changed.